,

วิธีการหลอกเวอร์ชันของ iOS


สำหรับท่านที่ต้องการลงแอปพลิเคชันที่ต้องการ iOS สูงๆ แต่เรามี Device ที่ต่ำกว่า iOS ที่แอปพลิเคชันนั้นๆต้องการ ผมมีวิธีมาเสนอกับแฟนๆ iPhonemod ทุกท่านครับ 😀

อ่านก่อนลงมือ

  • สำหรับวิธีการนี้ เครื่องต้อง Jailbreak แล้วเท่านั้น
  • ได้บางแอปเท่านั้น และ iPhone 2G สามารถเปลี่ยนได้ แต่ไม่ได้รองรับทุกแอป (สำหรับท่านใดที่จะทำเพื่อลง Line อย่างเดียว ขอให้ผ่านครับ ลงได้แต่เด้งครับ)
  • หากทำพลาด ทางทีมงาน iPhonemod ไม่ขอรับผิดชอบทุกกรณี
  • สำหรับ iOS5 user ถ้านำไปเล่นขำๆก็พอได้ครับ แต่ถ้าหากใช้จริงจัง เมื่อแก้แล้ว ให้แก้กลับเป็นแบบเดิมด้วยครับ เพราะถ้าหาก iOS เกิน 5.0.1 และ 5.1.1 cydia ก็จะอ่านไปอย่างนั้นจริงๆ และกรณีถ้าเกิดคุณลง tweak จาก cydia ตัว cydia ก็จะลบ Corona 5.0.1 Untether สำหรับคนที่ใช้ iOS 5.0.1 และ Rocky-Racoon 5.1.1 Untether สำหรับคนที่ใช้ iOS 5.1.1 ทำให้ Device เป็น tethered ทันทีครับ

เมื่อท่านยอมรับเงื่อนไขในข้างต้น และผมถือว่าทุกท่านทราบร่วมกันแล้ว สามารถลองได้ตามวิธีด้านล่างนี้เลยครับ

ให้ ssh ไปที่ /system/library/coreservices (คุณสามารถทำผ่าน iFile หรือโปรแกรมจัดการ iPhone อย่าง iFunbox ได้) แล้วเปิดไฟล์ ShstemVersion.plist

ad9-border

จากนั้นก็แก้ตัวเลขตามเส้นแดงครับ

อันนี้ผมก็แก้เป็น version 7.0 ไปแล้วนะครับ เอาล่ะ มาดูผลกันว่าจะเป็นอย่างไร

ใน setting.app ชัดเจนครับ เป็น 7.0 ไปแล้วครับ

และใน cydia เองก็เปลี่ยนเช่นกันครับ (เปลี่ยนกันยกเครื่องทีเดียว)

สำหรับท่านที่สนใจก็สามารถทำได้ครับ แต่ถ้าใครจะเอาไปทำขำๆกับเพื่อนคุณ ก็ถามเพื่อนก่อนนะครับ ว่าได้อ่านบทความทำนองนี้ (อันนี้) รึยัง ไม่งั้นเดี๋ยวหน้าแตกนะครับ 😛

ปล. สำหรับท่านที่ใช้ iPhone 2G ต้องการทำเพื่อลง Line Facebook etc. ทางทีมงานได้มีวิธีการในบื้องต้นแล้ว แต่ขาดอุปกรณ์ในการทดลองครับ เมื่อได้ผลแล้ว จะมาประกาศให้ทราบโดยทั่วกันครับ

ขอบคุณครับ

 

ความคิดเห็น - Like เพจ iPhoneMod.net
ad9-border

Written by attapon

ศิษย์เก่าวิศวกรรมคอมพิวเตอร์ ม. ขอนแก่น ผู้ก่อตั้ง iPhoneMod.net ตั้งแต่ปี 2009
อดีต Dell Technical Support รู้จัก ​Apple เพราะ Macbook Pro และใช้ iPhone ตั้งแต่รุ่น 3G จนถึงปัจจุบัน